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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

* Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

» Bold type is used for the following:

o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

° On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign > Port > Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter’ means to

press the key labeled Enter.
« |talic type is used for the following:

° Emphasis.

° The titles of publications.

o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

* The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key

or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

« The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line."

@ Al
O L.
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

* The menu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the File menu, click the Open Examples command" means you can click the File
menu and then click Open Examples to launch the dialog box.

* Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation > Port > Wave Port” means when you click the
right-mouse button with an object face selected, you can execute the excitation com-
mands from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu
To access help from the Help menu, click Help and select from the menu:
« [product name] Help - opens the contents of the help. This help includes the help for the
product and its Getting Started Guides.
* [product name] Scripting Help - opens the contents of the Scripting Guide.

* [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction

In this Getting Started guide, you will learn about dynamic linking capabilities between HFSS and
Circuit designs in the Ansys Electronics Desktop application. Specifically, the guide provides an
example of a matching network for a Bluetooth chip antenna.

By following the procedures in this guide, you will learn how to perform the following tasks:

¢ Dynamically link an HFSS design to a Circuit simulation

« Use the tuning feature in the Circuit design to match the antenna using lumped com-
ponents (you will tune the component values)

» Create S-parameter plots

* Apply a marker to a plot to assist in component tuning

« Push excitations from the Circuit design to the HFSS design

« Create gain plots (radiation pattern) and overlay them on the model geometry

You will begin with a partially completed project file containing a model of a Johanson evaluation
board, to which you will add a Johanson 2450AT18D0100001E Bluetooth chip antenna. There is
a completed example model of this evaluation board and antenna included with the Ansys Elec-
tronics Desktop installation (in the Examples\HFSS\Antennas subfolder). The related example
model demonstrates how to automatically optimize the matching network either in a Circuit
design linked to the HFSS design or entirely within the HFSS design. However, in this getting
started guide you will use an incomplete version of the example model (in the Help\HFSS sub-
folder) as your starting point, and you will learn how to tune the matching network manually.

The antenna is designed to work at a frequency in the range of 2.4 to 2.48 GHz. The following
images shows the evaluation board with the chip antenna mounted to it:
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3D Components
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The nextimage shows the linked HFSS evaluation board along with its matching network circuit:
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2 - Set Up the Project

In this chapter, you will perform the following tasks:

¢ Launch the Ansys Electronics Desktop application

Open the evaluation board project file

Enable legacy view orientations

Insert the chip antenna from the Components Libraries

Rename the predefined lumped port excitation

Launch Ansys Electronics Desktop

If the Ansys Electronics Desktop application is not already running, launch it now as follows:
1. Locate Ansys EM Suite 2025 R2 >m Ansys Electronics Desktop 2025 R2 in your
Windows Start menu's All Programs list to launch it.

Alternatively, click an Ansys EDT shortcut that you have pinned to the Start Menu or
Taskbar, or double-click a desktop shortcut you may have added.

The Ansys Electronics Desktop application opens:

! Ansys Electronics Desktop 2025 R2 - Project]
File Edit View Project Tools Window Help

- = T * | Save Archive , Cut Undo %
' |H H =" [
j e —AN ERestnre Archive Copy Redo [

Mew Open  Open Save Save  Close ) HF55 Q30 Circuit
Examples As 2, Paste X Delete - . -
Desktop View Simulation Automation Ansys Minerva Learning and Support
Project Manager 3 x
Note:

When you launch the application, a new, blank project is created automatically.
For this exercise, you will not start with a new project. Therefore, you will close it
in the next step.
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2. Right-click Projectx at the top of the Project Manager and choose Close from the shortcut
menu.

Open Project File

The project file for this exercise is located in the Help subfolder within the Ansys Electronics
Desktop installation path. The Program Files folders have restricted access permissions, and
besides, you shouldn't overwrite the sample models. Therefore, you will save the project to a suit-
able working folder after opening it.

- |

1. On the Desktop ribbon tab, click & Open Examples. Then:

a. Inthe Open dialog box that appears, click the parent folder icon (1) once to move
up one level above the Examples folder.

b. Double-click the Help folder and then the HFSS folder.
c. Select the file Chip_Antenna_Board.aedt and click Open.

The model appears in the Modeler window:
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Note:

This project is deliberately incomplete. You need to add the chip antenna to com-
plete the HFSS model. Additionally, you must insert a circuit design, add a port
and lumped components, configure the Circuit design excitation, add a frequency
sweep, tune the component values, push excitations from Circuit to HFSS, and
generate reports. For these reasons, the project file is located in the Help folder
instead of the Examples folder, which is reserved for completed projects.

Since you will not be constructing geometry for this exercise, the drawing grid and ruler
are hidden in the project file.

2. Onthe Desktop ribbon tab, click H Save As.
3. Navigate to a working folder of your choice. (Do not attempt to write to the program install-

ation path.)
Note:

Optionally, you can click the Create New Folder icon (I‘j" ) within the Save As
dialog box to create a new working folder in a suitable location.

4. Click Save to place a copy of the model in your working folder using the same file name.

Verify 3D Ul Options

Ensure that the legacy view orientation scheme is not being used, since the instructions and
images in this guide are based on the new view orientation scheme introduced in release 2024
R1. To ensure that the model views you see match those shown in this guide, do the following:

1. From the menu bar, click View > Options.
The 3D Ul Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is cleared:
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3D Ul Options

General | 3D Modeler Graphics I
[~ Stereo mode  (Affects only the newly created windows)
™ Drag Optimization

¥ Show Ansys logo
{Maximum number of values
displayed)

Default Color Key height: |16
When there iz a selection
¥ Selection always visible
[¥ Set transparency of selected objects 0.1

Iv Set transparency of non-selected objects  |0.9

Default Rotation About

" Model Center { Cument fxis * Screen Center ¢ Cursor

Gradual View Change
v Animate
Animation Duration

II”I]I””””””I 500 msecs

II_ Enable Legacy View Crentation I

Rendering Diagnostics

[ Display on-screen rendering diagnostics information

Diagnostics verbosity level: Level 1 -

™ Advanced Settings

3. Click OK.

Insert Chip Antenna

The chip antenna evaluation board has a relative coordinate system predefined (AntCS), which
has its origin specified at the proper antenna insertion point. The global origin is located at the
corner where the top (+2), left (-Y), and back (-X) sides of the board meet. You will use the pre-

defined AntCS coordinate system to add the antenna to the board.

Note:

The Johanson chip antenna is protected and encrypted. You cannot modify it in any
way other than moving it's location within the model.

1. Under Coordinate Systems in the History Tree, ensure that AntCS is the working coordin-
ate system. (A red "W" appears in the lower right corner of the icon when it is active.) If not,

select AntCS to make it active.
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2. With the cursor pointing at the AntCS origin, rotate the mouse wheel to zoom in closely to
the antenna insertion area, as shown in the following image.

The purpose is to ensure that you snap to the AntCS origin when placing the antenna and
not to any nearby vertex or grid point.

3. Ifthe Component Libraries window is not already visible, use the menu bar to toggle its vis-
ibility. (Click View > Component Libraries.)

4. Expandthe HFSS Components > Johanson > 2440MHz Antennas folder in the Com-
ponent Libraries window.

5. Right-click 2440MHz_ANTENNA_2450AT18D0100001E and choose Place Component
from the shortcut menu:
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Component Libraries o x

-4 Favortes
*‘[ﬁ Maost Recently Used
El'g HF55 Components
-1 ADAS
--L@ ADI mmWave Antenna Solutions
--1__] Antennas
-3 EMIEMC
--L@ HIROSE COMPONENTS
--1__] Human Body Exteriors
EIL@ Johanson Technalogy, Inc
#-1 Ceramic Chip Antennas (Sub-GHz)
--1__] Ceramic Chip Antennas (2.4GHz)
--1__] Ceramic Chip Antennas (Dualtand)
--1__] Ceramic Chip Antennas (5GHz LIWE)
--1__] Ceramic Chip Antennas (7GHz LWE)
--1__] Ceramic Chip Antennas (GMS5)
=-£3 2440MHz Antennas
----- @ 2440MHz_ANTEMMA_2450ATOVADT0000TT
----- @ 2440MHz_ANTEMMA_2450AT14A0700001T
----- @ 2440MHz_ANTEMMA_2450AT12A0T00001E
----- @ 2440MHz_ANTEMMA_2450AT18B0T00001E

----- - 2440MHz_ANTENNA 2450AT1800100001E

""" v 2440MH: Add To Favorites
----- @ 2440MHz
_____ @ 2440MHz Place Component

----- @ 2440MHz_ANTEMMA_2450AT42E010B001E
----- @ 2440MHz_ANTEMMA_2450AT43A0100001E
----- @ 2440MHz_ANTEMMA_2450AT43B0100001E
----- @ 2440MHz_ANTEMMA_2450AT45A0100001E
----- @ Z2500MHz_ANTEMMA_Z500AT44M0400001E
M- 5500MHz Antennas

The Insert 3D Component dialog box appears.

6. Ensure thatthe AntCS is selected from the Target Coordinate System drop-down
menu.

7. Click OK.
8. Point the cursor at the AntCS coordinate system origin and click the mouse to place the
component insertion point there.

The antenna appears at the correct position on the evaluation board:
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Note:

Alternatively, you could click and drag the antenna from the library to the Modeler
window, bypassing the Insert CD Component dialog box. Release the left mouse
button and then click again to drop the component anywhere in the Modeler win-

dow.

Tip:

Additionally, instead of snapping to a grid point or any snapping point on the geo-
metry, you can tab into the coordinate text boxes at the bottom of the user inter-
face and type in the exact coordinates for placing the component. For example,
to place the component at the origin of the selected coordinate system, press/-
type: Tab 0 Tab 0 Tab 0 Enter, making sure that the coordinate entry mode is

Absolute. Be careful not to bump the mouse while typing, or the coordinates will
be reset to the cursor location.

9. Click in the Modeler window's background area to clear the selection.
10. On the Draw ribbon tab, click == Fit All.

11. H Save your project. (This command is available from all ribbon tabs and from the File
menu.)

Set HPC Analysis Options

The high performance computing (HPC) capabilities of Ansys Electronics Desktop enable you to
take advantage of multiple processing cores, which are common on all high-end computer work-
stations. Different portions of the analysis can thereby be solved in parallel, shortening the solu-
tion time.

Note:

The supported number of cores is determined based on hardware and licensing
options. For the purpose of this exercise, use four cores, which is the supported num-
ber of cores for a basic software license.

.EEE

1. On the Simulation ribbon tab, click = HPC Options.

The HPC and Analysis Options dialog box appears.
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2. Ifthe configuration named Local does not say YES in the Active column, select this con-
figuration and click Make Active.
3. With Local still selected, click Edit.
4. Inthe Analysis Configuration dialog box that appears, specify the following settings:
a. Select Use Automatic Settings
b. Inthe Cores column for localhost, specify 4.

B Analysis Configuration

Configuration name: | Local

The local and interactive job configurations

Iv Use Automatic Settings -i——
Mum wariations to distribute: | 1 3:

Machines l Options ]

Machines for Distibuted Analysis
Total Enabled Cores: 4, GPU is enabled with SER+ solve anly

MName Cores | GPUs | RAM Limit (%) Enal:uleu:l|
localhost 4 1 50 [w

Machine Details:

* Local machine

5. Click OK twice to close the Analysis Configuration and HPC and Analysis Options dialog
boxes.

6. H Save your project.

Review the Simulation Setup

A boundary, four excitations, modified curved surface meshing, and the analysis setup and
sweep are predefined in the source project. The input port and tuning components have all been
defined as lumped ports, each assigned to a different sheet object. You can view the setup

details as follows:

1. Right-click HFSS_Circuit-Linked (Modal Network) in the Project Manager and choose
Solution Type from the shortcut menu. The settings are as shown in the following image:
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Solution Type: Chip_Antenna_Board - HFSS_Circuit-Link... X

Solution Types
+ HF55
" HFSS with Hybrid and Amraps
" Tranzient
" SBR+
" Eigenmode
" Characteristic Mode

Optionz

* Mebtwork Analysis ¢ Composite Excitation
+ todal " Temminal

[v &uto-Open Region
* Radiation " FE-BI " PML

[ Save as default

(] | Cancel

Notice that this is an HFSS modal network solution and that it includes an automatic open
region with a radiation boundary. You will not have to manually create an air or vacuum
region for this design.

2. Click Cancel to close the Solution Type dialog box without making any changes.
3. Under Boundaries in the Project Manager, double-click ground.
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Finite Conductivity Boundary x

Finite Conductivity Boundary l Defaults ]

MName: |§|I'DLII'IE|

Parameters

Conductivity: 58000000 Siemens./m
Relative Permeability: |'I

[ Use Material:

[ Infinite Ground Plane

Advanced
Surface Roughness Madel: {* Groiss " Huray
Surface Roughness: |D |um ﬂ
|
(" Set OC Thickness |C |mm ﬂ
« [
e [

* |se classic infinite thickness model

A conductivity of 58,000,000 Siemens/m is assigned to the ground sheet object on the bot-
tom face of the board, and Use classic infinite thickness model is selected.

Click Cancel to close the Finite Conductivity Boundary dialog box without making any
changes.

Under Excitations in the Project Manager, select each of the four predefined excitations,
one-at-a-time, to see their settings in the docked Properties window.

All four excitations are lumped ports with 50 Q full port impedance and with Deembed
and Renormalize All Modes selected. While each excitation is selected, you can also
see the lumped port visualization on the model, including its defined integration line.
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.: iél i

« P1:
Properties I x
Mame Value | Linit IEvaIuated Value
Mame P1
Type Lumped Port
Assignment F1
Impedance 50 ohm Hlohm
Mum Modes 1
Deembed |7
Renom All Modes |7
Renom Impedance Type | Impedance
Renom Imped 50 ohm Hlohm
HF55
* Series:
Properties I x
Mame Value | Linit IEvaIuated ‘u"aluel

Mame Sefies
Type Lumped Port
Assignment series
Impedance 50 ohm Hlohm
Mum Modes 1
Deembed |7
Renom All Modes |7
Renom Impedance Type | Impedance
Renom Imped 50 ohm Hlohm

HF55

¢ Shunt1:
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information of ANSYS, Inc. and its subsidiaries and affiliates.

Set Up the Project 2-12




Getting Started with HFSS™: Matching Network — Using Tuning in Circuits

Properties 1 x
MName Walue | Uit | Evaluated Value
MName Shurit1
Type Lumped Port
Assignment shurtt1
Impedance 50 ohm Hlohm
Mum Modes 1
Deembed [w
Renom All Modes [w
Renom Impedance Type | Impedance
Renom Imped 50 ohm Hlohm
HF55

¢ Shunt2:
Properties I x
Mame Value | Linit | Evaluated Value
Mame Shunt2
Type Lumped Port
Assignment shunt2
Impedance 50 ohm Hlohm
Mum Modes 1
Deembed [w
Renom All Modes [w
Renom Impedance Type | Impedance
Renom Imped 50 ohm Hlohm
HFSS

6. Right-click Mesh in the Project Manager and choose Initial Mesh Settings.
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Curved Surface Meshing

[ Use dynamic suface resolution

* |se Slider " Manual Settings
Coarse Resolution Fine
1 1
B
_I'—
Small Mesh Count Large

The Curved Surface Meshing slider has been moved three ticks coarser than the default
position. This setting only affects curved geometry, which, for this example, is limited to
the vias connecting the top and bottom ground planes. The default curved surface res-
olution would be unnecessarily fine for these vias and would significantly increase the ele-
ment count, solution time, and memory requirement without improving the results.

7. Under Analysis in the project manager, double-click Bluetooth to see the analysis prop-
erties, which are summarized as follows:
¢ General tab:
o Adaptive Solution Frequency = 2.44 GHz
° Maximum Number of Passes - 7
° Maximum Delta S =0.02
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Driven Solution Setup x
Advanced ] Expregsion Cache ] Dervatives ] Defaults ]
General l Mesh/Solution Options ] Adaptive Options
Setup Mame

[v Enabled [ Solve Ports Only
Adaptive Solutions

Solution Frequency: & single (" MultiFrequencies (" Broadband

Frequency | 2,944 |GH2 ﬂ
Maximum Mumber of Passes 7
{* Maximum Delta 5 0.02

(" |Use Matrix Convergence

+ Advanced tab: Save Fields is enabled for all objects:

* Mesh/Solution Options tab: Auto-select Direct/lIterative is selected. All other set-
tings in this tab are the defaults.

8. Click Cancel to close the Driven Solution Setup dialog box without making any changes.

9. Under Analysis > Bluetooth in the Project Manager, double-click 1_4GHz to see the fre-
quency sweep definition.
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Edit Frequency Sweep s
General l Imtemolation ] Defaults ]
Sweep Mame: [+ Enabled

Sweep Type: |Ir|ter|:u:|Iating ﬂ

Frequency Sweeps [601 points defined]

Distribution Start End

M | inear Step

Add Above Add Below Preview ... |

A0 Fields Save Options

Time Domain Calculation... |
[v Save Fields (4 Basis Freqs)

v Save radiated fields only o

[1 IMHz |
| oK | Cancel |

Here you can see that the sweep is in linear steps of 0.005 GHz from 1 to 4 GHz, with a
total of 601 points, and the radiated fields will be saved.

Additionally, three project variables have been predefined. We will look at those in a later pro-
cedure.
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3 - Validate and Analyze HFSS Design

Verify that there are no model setup errors and run the HFSS simulation as follows:

1. On the Simulation ribbon tab, click J Validate.

The Validation Check window appears, and it should show no warnings or errors:

Validation Check: Chip_Antenna_Beard - HF55_Circuit-Linked X
] ¥ Design Settings
& HFSsDesignt 30 Mode]

¥ Boundaries and E =citations

"W alidation Check completed. ' Mesh Operations
" Analysis Setup
¥ Optimetrics
" Radiation

2. Click Close to dismiss the Validation Check window.

3. On the Simulation ribbon tab, click (o} Analyze All.

Note:

The Validate and Analyze All commands are also available from the HFSS menu
and from the shortcut menu that appears when you right-click the HFSS design in
the Project Manager.

4. If the Message Manager and Progress windows are not displayed, click Show Messages
and Show Progress, at the right end of the status bar, to see the solution messages and
progress.

5. Optionally, click and drag the borders to resize these windows as preferred.

The HFSS solution takes about four minutes or less to solve using four cores on a reasonably
current computer workstation.
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4 - Set Up and Analyze Circuit Design

In this chapter, you will perform the following tasks:

Insert a Circuit design into the project

Add a link to the HFSS design in the Circuit design

Add a port to the HFSS model's schematic in the Circuit design
Add lumped components to the Circuit design

Connect components in the schematic

Configure the Circuit design excitation

Review the port source properties

Insert Circuit Design

You will add the matching network components and perform their tuning in a Circuit design. Add
one to the project as follows:

. When the HFSS analysis has finished solving, H Save the project.
. On the Desktop ribbon tab, click Circuit.

The Workflow dialog box appears.

In the list at the right side of the Workflow dialog box, ensure that None is selected and
click OK.

An empty Schematic window appears and a Circuit1 branch is added to the tree in the Pro-
ject Manager.

In the Project Manager, collapse the HFSS_Circuit-Linked (Modal Network) branch,
and expand the Circuit1 branch (if it is not already expanded).

Right-click Circuit1 and choose Rename.
Type Matching Network and press Enter.

Add HFSS Model to Circuit

In this procedure, you will copy the HFSS design of the evaluation board and chip antenna into
the Circuit design.

1.

In the Project Manager, right-click Matching Network and choose Add Subcircuit > Add
HFSS Link from the shortcut menu.

The HFSS Dynamic Link dialog box appears.
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2. On the left side of the dialog box, under Chip_Antenna_Board > HFSS _Circuit-Linked,
select the frequency sweep (Bluetooth : 1_4GHz):

B ' HF55 Dynamic Link

El--lm Chip_Antenna_Board

: Mame: HFSS_Circuit-Linked1
El-g# HFSS_Circuit-Linked | -

S allBlustooth : 1_4GHz

f ) Bluetooth : LastAdaptive Description: |

[ Transmission line model ~ |pq

Link Information
Solution: Interpolating sweep 1 GHz-4 GHz (Solved)

Number of frequency points: 601
Number of pins: 4

Open Project ... oK | Cancel

3. Click OK.

A subcircuit model of the HFSS design is inserted into the Matching Network (Circuit)
design in the Program Manager. A number "1" has been appended to the end of the
source HFSS design name.

El--lm Chip_Antenna_Board*
g HFSS_Circuit-Linked (Modal Netwark)
El-li Matching Network™
Data
@ Excitations
; Ports
{é":i S1:HFSS_Circuit-Linked1

28F Analysis

-7 Definitions

The HFSS model also appears in the Schematic window.
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4. On the Schematic ribbon tab, click Fit All. Then, click €, Zoom Out twice to make
room in the Schematic window for adding some components.

HFSS_Circuit-Linked1

AN

P1 Shunt1

Series ,
—t]

el
- 0
| e L
LaE -
e
-

Note:

Zoom in or out and scroll in the Schematic window as needed while completing
the circuit. The mouse buttons and scroll wheel work somewhat differently in the
Schematic window than they do in the 3D Modeler. Roll the mouse wheel to
zoom in or out, as in the 3D Modeler. Press Shift while rolling the wheel, or use
the scroll bar on the right edge of the window, to scroll the schematic vertically.
Use the bottom scroll bar to scroll horizontally.

Add Port to Schematic

Add an interface port to the schematic. Then, connect it to pin 1 of the HFSS evaluation board
model you added to the schematic in the last procedure.

1. On the Schematic ribbon tab, click ? Interface port.

2. Place the port symbol on the schematic in the approximate position shown below. When
you click, the insertion point of the symbol will snap to the nearest grid point.
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HFSS_Circuit-Linked1

P1 s
ort1 B P
Series . [Shunt2

=
-
=3
—
—

3. Right-click and choose Finish to exit the Interface port command (alternatively, press
Space or Esc).

4. Pointto the bottom end of the Port1 pin (but do not click yet).

The cursor changes to an X when near a valid connection point.

ort1

5. Click this point.

The Wire command is started automatically, and the start point of the wire snaps to the
Port1 pin.

6. Inthe same manner, click the mouse at the pin labeled 1. (A small circle indicates the
snapping point.)

The completed connection wire should match the following image:
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ort1 P1

Series
E_

o

“

Because the line completes a connection to a pin, the segment is terminated. Otherwise, if
you clicked at a non-connection point (say to change directions) you can continue to draw
line segments until a valid termination point is reached.

Add Components to Schematic

Next, you will add two capacitors and one inductor to the schematic. You will also specify the
appropriate parameters and values.

1. Navigate to the Components tab of the Component Libraries window.
2. Under Nexxim Circuit Elements, expand the Capacitors branch.

Component Libraries

o2 Favorites

¥ Most Recertly Lsed

Mesedim Circuit Elements
=@l BJTs

ElﬂI Capacitors

N ST CAP_: Capacitor

H+ C}-‘-.P:Deuice: Capacitor with parameters

CAP_Device_Model: Capacitor Model

3. Click and drag the component labeled CAP_: Capacitor onto the right side of the schem-
atic. Then move the cursor and click again to place a second one on the right side, below
the first. Locate the two capacitors at the approximate positions shown below:
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10.

HFSS_Circuit-Linked1

2
=y
c
3
—
—

- C36 ‘ ‘

<X - 1e-12farad

e C37 | |
= =
||

!

%Cﬂ
=y
c
=

N

't

1e-12farad

Right-click and choose Finish (or press Space or Esc) to terminate the component place-
ment operation.

Click the upper capacitor to select it.
The settings associated with this component appear in the docked Properties window.

In the Param Values tab of the docked Properties window, replace the default numerical
Value of C with a variable, C1, and press Enter.

In the Add Variable dialog box that appears, do the following:

a. Select Capacitance from the Unit Type drop-down menu (if it is not already selec-
ted).

b. Select pF from the Units drop-down menu.
c. Type 2in the Value text box.
d. Click OK.

In the Component tab of the docked Properties window, change the InstanceName
Value to C1 ifitis not already specified as such.

Setting both the InstanceName and the variable name to C7 makes it easy to tell which
variable goes with which component. You'll do the same for the remaining components.

Repeat steps 5 through 8 for the lower capacitor. This time, specify C2 for both the vari-
able and the InstanceName and set the value of variable C2 to 1.5 pF.

Under Nexxim Circuit Elements, expand the Inductors branch.
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11.
12.

13.
14.

15.

16.

17.

18.

ﬂj Ideal Microwave

; Independent Sources
Inductors

[ IND_: Inductor
- IND:Device: Inductor with parameters
----- s |MO_Poly: Inductar, Polynomial

Double-click the component labeled IND_: Inductor.

Right-click at the desired inductor insertion point on the left side of the schematic (as
shown below) and choose Place and Finish from the shortcut menu.

\T;;n1 P1
Series
[ ..
.
b -

1e-09

Click the inductor you just placed on the schematic to select it.

In the Param Values tab of the docked Properties window, replace the default numerical
value of L with a variable, L1, and press Enter.

In the Add Variable dialog box that appears, do the following:

a. Select Inductance from the Unit Type drop-down menu (if it is not already selec-
ted).

b. Select nH from the Units drop-down menu.
c. Type 3.6 in the Value text box.
d. Click OK.

In the Component tab of the docked Properties window, change the InstanceName
Value to L1 if it is not already specified as such.

In the Schematic window, click and drag the Design Properties box and the HFSS_Cir-
cuit-Linked1 name to approximately center them at the top and bottom of the schematic,
respectively.

Click in the background to clear the current selection.

The schematic should resemble the following image:
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HFSS_Circuit-Linked1

C1

=V ‘ il
=

L1 |

C2

Design Properties
C1=2pF

C2 =1.5pF

L1 = 3.6nH

Connect Components in Schematic

Next, you will connect the discrete components just added to the schematic to the appropriate
points on the evaluation board.

1. Click the right end of inductor L1 to start a connection line, click two intermediate points,
and click pin Series to terminate the connection.

Note:

In a proper schematic, diagonal connection lines are avoided. The intermediate
points enable a multi-segment connection in which all line segments are ortho-
gonal. This connection should resemble the following image when completed:
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TPorH P1
Series

L1
a2 Y e -
L1

£

2. Inthe same manner, add the following three connections:
¢ Left end of C1 to pin Shunt1
» Left end of C2 to pin Shunt2
« Right end of C1 to Right end of C2

#shuntt  C1

||
., [Shunt2 \ N
-

C1

7 ‘32||

3

_—7

On the Schematic ribbon tab, click = Ground.

Click to connect the Ground to the left end of L1.

Click to connect a second Ground to the right end of C2.
Press Space to exit the Ground command.

N o o bk ow

Click in the background to clear the selection.

The finished schematic should resemble the following image:
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HFSS_Circuit-Linked1

Port1 P1 |Shunt1 C1 ||
Series| g i (Shunt2 ||
$C1
L1 i C2
O b
$L1 1o
—+ $C2  —

8. H Save the project.

Configure Circuit Excitation

In this procedure, you will add a 1 volt peak magnitude AC power source to the circuit's Port1
configuration.

1. Under Matching_Network in the Project Manager, right-click Excitations and choose Con-
figure Sources from the shortcut menu.

The Configure ports and sources dialog box appears. Port1 is already selected because
it's the only item in the Ports List.

2. From the drop-down menus in the Add New Source section of the dialog box, choose
Power and Sinusoidal (if not already selected). Then click Add to selected port:
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B Configure ports and sources

Ports List - |5h|:|w all sources

=]

Description | Indude

Analysis list

Mame | Mame

Add MNew Source

N

|F'|:|wer ﬂ |Sinusu:uiu:|a|

The Properties dialog box appears.

3. Forthe parameter ACMAG, specify a value of 1 V:

Add to selected port |

Parameter Values l

Properties: Chip_Antenna_Board - Matching_Metwork

Mame | Value | it |E1.raluated "u"alue|

Description

MName PowerSinu ..

ACPHASE 0 deg (deg
DC 0 W o

Note:

AC magnitude for smallsignal analysis (Volts)

AL phase for small-signal analysis

DC voltage (Valts)

This voltage is the peak magnitude of the AC signal, not peak-to-peak. The peak-
to-peak amplitude = 2 * ACMAG, and the average amplitude = ACMAG / V2.

4. Click OK to close the Properties dialog box.

5. Click OK to close the Configure ports and sources dialog box.

Add Frequency Sweep and Analyze

You will now set up a frequency sweep in the Circuit design spanning from 1 to 4 GHz in 0.005

GHz increments.
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. On the Simulation ribbon tab, click PEE LNA. (If LNA is not shown as the default action
for any of the simulation type drop-down menus, select it from the first drop-down menu.)

After clicking the icon, the default action is to set up a Nexxim, Linear Network Analysis
(LNA).

The Linear Network Analysis, Frequency Domain dialog box appears.

. Immediately below the Sweep Variables table, click Add.

. Inthe Add/Edit Sweep dialog box that appears, specify the following settings:
a. Selectthe Linear step option.

b. Start=1 GHz

c. Stop=4 GHz

d. Step=0.005 GHz

. Click Add to populate the Sweep Values box.

B Add/Edit Sweep

Wariable Freq ﬂ
Sweep Values
' Single value Start \ LIM 1GHz 4GHz 0.005GH=
{* Linear step I GHz ~|

" Linear count Stop

<< Remaove
" Decade count |4 |'3H2 ﬂ
" Octave count Step Delete

[0.005 GHz ~|

. Click OK to close the Add/Edit Sweep dialog box.
. Click OK to close the Linear Network Analysis, Frequency Domain dialog box.

The Circuit design is ready to be analyzed.

. On the Simulation ribbon tab, click (o Analyze.

The Circuit simulation only takes a second or two to finish.
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5 - Tune Matching Network

In this chapter, you will tune the component values in the matching network to minimize the sig-
nal reflection at 2.44 GHz. The goal is for the circuit and antenna to be resonant at this fre-
quency. The process involves the following steps:

» Create an S-parameter plot

» Prepare the S-parameter plot for circuit tuning

* Select the variables to be tuned
¢ Tune component values

Create S-Parameter Report

The first step in tuning the circuit is to create an S-parameter report of the signal reflection (or
return loss) at Port1. This plot will be used as the basis of the component tunings to be per-
formed. The signal reflection will be minimal at the resonant frequency of the circuit. Varying the

capacitance and inductance values will alter the resonant frequency of the circuit.

1.
2.

lowing image:

On the Results ribbon tab, click
In the Report dialog box that appears, ensure that all settings are as shown in the fol-

o

(_( Standard Report >

B |
."x-\lﬂulll Ill,\

2D.

Q Report: Chip_Antenna_Board - Matching_Metwork - Mew Report - Mew Trace(s)

Trace l Families ] Families Display ]

=]

|LinearFrequency

j X

Context

Solution;

Domain: |5weep
Update Repart

[v Real time

Primary Sweep: |FFEE|

||

[+ Default | Freg

¥ |dB(5(Port1,Part1))

Category:

Variahles

Y Parameter
Z Parameter
Voltage
Current
Return Loss
YEWR

OuEut Variables

[

Quantity: ~
S(Port1,Portl)

ot
]
]
Range
Function...

Function:

ang_deqg
ang_deg_val
ang_rad
arg
cang_deqg
cang_deg_val
cang_rad

~

dB10normalize ¥
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3. Click New Report and click Close.

S Parameter Plot 1 appears in a new window:

S Parameter Plot1 Matching Metwork
0

iy
§ 4 _‘ — dB(S(Port1,Port1))
=] LinearFrequency
o, i
T i
5 i
o i
ZR
M i
-D -

-5 —

'1[} T T T T | T T T T | T T T T | T T T T | T T T T | T T T

1.0 1.5 20 25 3.0 35 4.0
Freq [GHz]

Prepare Report for Tuning

In this procedure, you'll modify the Y scaling of the S-parameter plot and add an X-marker at the
desired resonant frequency of 2.44 GHz.

1. Click on the Y axis of S Parameter Plot 1 to select it.

The Y axis becomes bold, and the associated settings appear in the docked Properties
window.
2. Inthe Scaling tab of the docked Properties window, make the following changes:
a. Select the Specify Min option.
b. Change the Min value to -70 and press Enter.
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Properties
Mame Value

Auis Scaling | Linear
Specify Min [w
Min -70
Specify Max [
Max 0
Specify Sp... [
Spacing b
Minor Tick...| 5

[ | Sealing || Cartesian | General |

3. Right-click in the S Parameter Plot 1 window and choose Marker > Add X Marker.

A vertical marker line is added to the plot. The bottom yellow box indicates the frequency
value and the top one the corresponding S-parameter value.

4. Clickinside the bottom yellow marker box (frequency).
The X marker settings appear in the docked Properties window.

5. Inthe X Marker tab of the docked Properties window, scroll down to the properties under
the Selected heading (if necessary) and make the following changes:

a. Selectthe Lock Drag option.
b. Change XValue to 2.44 GHz.
c. Change Line Width to 2 and press Enter.
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Properties
Name Value | Linit |
Del Line Width 1
Del¥ Fart Fort |
Selected -S——
Mame M1
Show Intersections [v
Lock Drag [w
¥Value 244 GHz
Box Background [ |
Font Font |
Line Color [
Line Width 2
Line Style Dash

I}{ Markerll Cartesian ] General ]

6. Click in the plot background area to clear the selection.

The modified plot should look like the following image:
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S Parameter Plot1 Matching Metwork

=)

L
=

¥
=

|
[ %]
=)

— dB(5(Port1,Port1))
LinearFrequency

I
(=1

dB(S({Port1,Port1))

|
n
=

&
(=1

|
=]
=

=y
=)
=y
[
[
=)

D5 3.0 35
Fm$[GHﬂ

XIS

Select Variables for Tuning

You must specify which variables you want to include in the tuning process. You will include all
three of the previously defined variables: C71, C2, and L1.

1. Inthe Project Manager, right-click Matching Network and choose Design Properties
from the shortcut menu.

2. Inthe Local Variables tab of the Properties dialog box that appears, make the following
changes:

a. Select the Tuning option.

b. Select the checkboxes in the Include column for all three variables (Shunt1,
Shunt2, and Series).

c. Inthe Min, Max, and Step columns, set the values as shown in the following image:
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Project Variables | intrinsic: Variables | Constarts |

" Value " Optimization / Design of Experiments * Tuning " Senstivity (" Statistics
Mame | Include | Nominal Value | Min | Uit | Max | Unit | Step | Uit |
sC1 [vw ZnF 1 pF 3 pF 0.05 pF
sC2 [vw 1.5pF 075 pF 225 pF 0.05 pF
g1 [vw 3 6nH 2 nH 5 nH 0.05 nH

3. Click OKto accept the settings and close the Properties dialog box.

Tune Component Values

In this procedure, you will determine the $C7, $C2, and $L 7 component values that provide the
minimal S(Port1,Port1) parameter (signal reflection or return loss) at a frequency of 2.44 GHz.
Your results may differ somewhat from those shown on this page. Meshing and solution char-
acteristics can vary slightly between different versions of the software and on different platforms.
For example, the same component values may result in the minimum return loss at a frequency
other than 2.44 GHz, or your decibel value may be somewhat different. Try to achieve a return
loss no greater than -40 dB at 2.44 GHz.

1. Bring the S Parameter Plot 1 window back to the foreground using one of the following
methods:

« |fthe plot window is partially visible, just click anywhere in the window or on its title
bar.

¢ Using the Window menu, select Chip_Antenna_Board - Matching Network - S
Parameter Plot 1.

» Under Matching Network > Results in the Project Manager, double-click S Para-
meter Plot 1. (This method will reopen the plot window if you previously closed it.)

2. Under Matching Network in the Project Manager, right-click Optimetrics and choose Tun-
ing from the shortcut menu. Alternatively, using the menu bar, click Circuit > Tune.

3. To provide an unobstructed view of the S Parameter plot, particularly in the area around
2.44 GHz, reposition the Tune dialog box that appears. (Do this by clicking and dragging
its title bar.)

4. Clear the Browse available variations option in the Tune dialog box.

5. For each of the three variables in the Variations section, slowly drag the sliding pointers
upward and downward to adjust the values within the Min to Max range. Allow sufficient
time for the plot to update at each component value step. The goal is to minimize the value
at the point of intersection of the plot trace and the X marker line. This set of adjustments
is tricky because the three components have a complex interaction. You can't alter one
variable without affecting the optimal setting for the other two variables.
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The Tune dialog box and updated S Parameter Plot 1 should resemble the following two
images when you reach the optimal settings:

¢4 Tune - Matching Network = X
Iv Feal time | Accumulate W ariation:
Sim. Setups Ture b x| |

LinearFrequency [ [ [
$C1 pF $C2 pF $L1 nH

3

[ Browse available wvariations I

M aminal; E M arminal; : M aminal;

; 145 - 13 . 245 -
oy | - :

| | N :

Save | | E N E

|
:
.

0v

Reset | Cloze | J J
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S Parameter Plot1 Matching Metwork
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. Close the Tuning dialog box.
The Apply Tuned Variation dialog box appears.

. Click OK to apply the selected variation, which represents the current slider positions.

H Save the project.
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6 - Push Excitations

Push the excitation information from the Circuit design to the HFSS design as follows:

1. Bring the Schematic window back to the foreground using one of the following methods:

 Ifthe Schematic window is partially visible, just click anywhere in the window or on
its title bar.

» Using the Window menu, select Chip_Antenna_Board - Matching Network -
Schematic.

¢ Using the menu bar, click Circuit > Schematic Editor.
¢ Inthe Project Manager, double-click Matching Network.

2. Inthe Schematic window, right-click the HFSS design component (evaluation board) and
choose Push Excitations from the shortcut menu.

The Push Excitation Information dialog box appears:

Push Excitation Information *
Solution: |LinearFrequency j [ Calculate Thevenin Impedance
Start Time: s = Window Type: |Hamming J

Stop Time: 10s _|:I Kaiser Param: | 0
Max Harmonics: | 100

Resolution Bandwidth: | Maximum Freguency:
QK | Cancel |

3. Click OK.
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7 - Verify Excitation Data in HFSS

Next, verify that the excitation information has been transferred from the Circuit design to the
HFSS design. This information includes the following items:

» Frequency-dependent port excitation magnitude data (four datasets)

* Frequency-dependent port excitation phase data (four datasets)

« System power

1. Inthe Project Manager, collapse the Matching Network branch and expand the HFSS_
Circuit-Linked (Modal Network) branch.

2. Double-click HFSS_Circuit-Linked (Modal Network) to make it the active design and to
bring the Modeler window to the foreground.

3. Under HFSS_Circuit-Linked (Modal Network) in the Project Manager, right-click Excit-
ations and choose Edit Sources from the shortcut menu.

The Edit post process sources dialog box appears.

4. Inthe Spectral Fields tab of the dialog box, ensure that the Specify System Power option
is selected under System power for gain calculations:

[HF55Designl] Edit post process sources

SEemraI Fields | Source Context

Source Type Magnitude Uit Phase Uit
E H H
2 Series: 1 Paort pwlimode_Seres_mag.Freq) pwlimode_Seres_phs, Freq)
31 Shuntl:1 Port pwlimode_Shurt1_mag,Freq) pwlimode_Shunt1_phs,Freq)
4 Shunt2:1 Paort pwlimode_Shurt?_mag.Freq) pwlimode_Shurt?_phs Freq)
[¥ Include Port Post Processing Effects [ Weighted Hement Pattem Post Processing Mode

System power for gain calculations:
* Specify System Power: |D.DD25 |W ﬂ

" Use Maximum Available Power

The system power value has been updated to reflect the excitation defined in the circuit
schematic, as explained below:
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* The specified peak AC magnitude is 1 V with a 50 Q generator impedance.

* The chip antenna board's portimpedance is also 50 Q. Therefore, the voltage
divides in half across the two equal series impedances, resulting in a 0.5 V peak
magnitude at the HFSS port.

« The system power is V2/2Z =0.52 /100 = 0.0025 W
e Thepeakcurrent(J)isV/Z=0.5/50=0.01A
* The system power can also be expressed asVJ/2=0.5*0.01/2=0.0025 W

Also, notice that the Magnitude and Phase columns contain references to frequency-
dependent magnitude and phase datasets. Prior to pushing the excitation information
from the Circuit design, this dialog box would have shown 1 W magnitude at 0° phase for
the first port and all zeros for the magnitude and phase values of the other three ports.

5. Click OK.
6. Using the menu bar, click HFSS > Design Datasets.

The Datasets dialog box appears.

7. Select any of the listed datasets to see a graph of the frequency-dependent magnitude or
phase data.

Two of the eight dataset graphs are shown below:

Mame | Add...
1 |mode_P1_mag Ed

[t
]
m
o

" Bemove ¥
3 |mode_Seres_mag

4 Imode_Series_phs Clone..

5 |mode_Shunt1_mag Impaort...
imude_Shunt'IJ:uhs el {25515
7 |mode_ShuntZ_mag

8 |mode_Shurt2_phs SheetScan...

-2.50E-15

SEEN T
1.00E+09 200E+09 JE+D
X

Daone

el
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Mame | Add. .. | 375E-03
1 |mode_P1_mag Edit
2 \mode_P1_phs
— R - ]
_3 mode_Series_mag nemove p—
4 |mode_Series_phs Clone... 1
_5 mode_Shunt1_mag Import... >
& |\mode_Shurt1_phs E— i 1
port... E-03
# |mode_Shurt2_phs SheetScan...
OO0 ]
Done 1.005+09 2005409 . 2005+09

8. Click Done.

Verify Excitation Data in HFSS 7-3
Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Matching Network — Using Tuning in Circuits

8 - Create and Overlay Gain Plots

Create two Total System Gain versus Theta plots, one at Phi = 0° and one at Phi = 90°. Gain
plots are far fields reports showing the antenna's radiation pattern. You could plot both Phi val-
ues as two traces on a single plot. However, after creating the plots, you will overlay the radiation
patterns on the model geometry to better visualize the radiation patterns in different directions.
To qualify for overlaying, a 2D polar plot cannot contain multiple Phi values. However, you can
overlay multiple individual 2D polar plots, each based on a single Phi values.

These System Gain plots will include the effects of the tuning performed in the Matching Network
(Circuit) design and pushed to the HFSS excitation sources. Create and overlay them as follows:

1. On the Results ribbon tab, click “ Far Fields Report > Mag/Ang Polar.

2. Inthe Report dialog box that appears, specify the following settings:
a. Select Elevation from the Geometry drop-down menu.
b. Ensure that all settings under the Trace tab are as shown below:

&5 Report: Chip_Antenna_Board - HFSS - Circuit Connected - New Report - New Trace(s)

Context Trace l Families ] Families Display ]

Solution: |Ei|ueb:u:uﬂ'| : Lastﬁ.dapﬁveﬂ

Geometry: |[SEFER -

Primary Sweep: |Theta ﬂ |.-5.||

et
Mag: ||:|Ei|:5ystemGainTDtal]l ES.:?EW, .

Category: Quantity: b Function:

Ang: W Default | Theta

Variables SystemGainTotal ang_rad
Cutput Variables SystemGainPhi asin
Gain ) asinh
SystemGainTheta ‘ atan
E SystemGainX atanh
Directivity SystemGainy oS
Realized Gain SystemGainZ cosh

Update Report F‘u:ullarlzah!:n Ratio SystemGainLHCP cum_integ
Axial Ratio cum_sum

v Real time Design — B |

3. Under the Families tab, select the Phi value of 0deg, as shown below:

Create and Overlay Gain Plots 8-1
Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.




Getting Started with HFSS™: Matching Network — Using Tuning in Circuits

Trace Families | Families Displa*_.']

Families : 1 available

v Sweeps {  Available variations

Variable Value Edit

" Use all values ﬂ

Freq 2.949GHz
* Select values ©

5C1 Mominal

§2  Nominal W
deg
. Q0

g1 Mominal

Nominals: | $C1, $C2, §L1 ]

Select All | Clear all

New Report | Apply Trace | Add Trace | €195 Sweep: & pefauit J

4. Click New Report but keep the dialog box open.

System Gain Plot 1 appears in a new window:
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System Gain Plot1 HFSS - Circuit Connected
0

— dB(SystemGainTotal)
Bluetooth : LastAdaptive
Freq="2.44GHz' Phi='"0deg’

-180

5. Inthe Families tab of the Report dialog box, select the Phi value of 90deg.
6. Click New Report and click Close.

System Gain Plot 2 appears in a new window.

To differentiate the appearance of the two gain plot curves, you will next change the color
of the trace in System Gain Plot 2.

7. Click the trace in System Gain Plot 2 to select it.

8. Inthe docked Properties window, change the Color value from red to medium blue
(column 6, row 1 of the Basic colors; Red: 0, Green: 128, Blue: 255) and click OK.

The modified plot should look like the following image:
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System Gain Plot2 HFSS - Circuit Connected

0 —— dB(SystemGainTotal)
Bluetooth : LastAdaptive
Freq="2.44GHz" Phi="30deg’

-180

9. Use the Window menu to bring the Modeler window to the foreground (Chip_Antenna_
Board - HFSSDesignx - Modeler).

10. Right-click in the Modeler window and choose Plot Fields > Radiation Field.
11. Inthe Overlay radiation field dialog box that appears, specify the following settings:

B Owerlay Radiation Field: Chip_Antenna_Board - HF55Design X
Mame | Visible | Transparency Scale Type
Realized Gain Plot2 [w 0.90 0.25 D
Realized Gain Plot1 [v 0.90 0.25 2D
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12. Click Apply and then Close.

13. With the cursor near the upper-left corner of the Modeler window's display area, press and
hold Alt while double-clicking the left mouse button. This action produces an alternative

isometric view of the model with the back side facing towards you.

Note:

This viewpoint prevents a significant portion of the red and blue traces from being

hidden by the evaluation board.

The overlaid plots should resemble the following image:

30 30

3D Components

JOHANSOMN
TEIL o

AMNTEMMA 24504-
T18D010001E en-
crypt
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14. H Save the project.

You have completed the Matching Network getting started guide. Simulating manual tuning of
the network is useful because it gives you a good idea about the complex interactions of the
actual tuning components and how they behave when performing an alignment on the work-
bench. Again, if you would like to see how to automatically optimize the matching network tun-

ing, either using a linked Circuit design or doing so entirely within HFSS alone, please refer to
the Johanson 2450AT18D0100-EB1SMA example model.
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